CVE-2023-5917
CVE-2023-5917 · phpBB Smiley Pack acp_icons.php main cross site scripting
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acp_icons.php of the component Smiley Pack Handler. The manipulation of the argument pak leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.
CVSS 2.4 · Low · EPSS 0.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
phpbb
- Versions
- 3.3.0: Affected
- 3.3.1: Affected
- 3.3.2: Affected
- 3.3.3: Affected
- 3.3.4: Affected
- 3.3.5: Affected
- 3.3.6: Affected
- 3.3.7: Affected
- 3.3.8: Affected
- 3.3.9: Affected
- 3.3.10: Affected
No fix published
phpbb/phpbb Packagist
- Versions
- 3.0.12
- 3.0.12-RC1
- 3.0.12-RC2
- 3.0.12-RC3
- 3.0.13
- 3.0.13-PL1
- 3.0.13-RC1
- 3.0.14
- 3.0.14-RC1
- 3.1.0
- 3.1.0-RC1
- 3.1.0-RC2
- 3.1.0-RC3
- 3.1.0-RC4
- 3.1.0-RC5
- 3.1.0-RC6
- 3.1.0-a1
- 3.1.0-a2
- 3.1.0-a3
- 3.1.0-b1
- 3.1.0-b2
- 3.1.0-b3
- 3.1.0-b4
- 3.1.1
- 3.1.10
- 3.1.10-RC1
- 3.1.11
- 3.1.11-RC1
- 3.1.12
- 3.1.2
- 3.1.2-RC1
- 3.1.3
- 3.1.3-RC1
- 3.1.3-RC2
- 3.1.4
- 3.1.4-RC1
- 3.1.4-RC2
- 3.1.5
- 3.1.5-RC1
- 3.1.6
- 3.1.6-RC1
- 3.1.7
- 3.1.7-RC1
- 3.1.7-pl1
- 3.1.8
- 3.1.8-RC1
- 3.1.9
- 3.1.9-RC1
- 3.2.0
- 3.2.0-RC1
- 3.2.0-RC2
- 3.2.0-a1
- 3.2.0-b2
- 3.2.1
- 3.2.1-RC1
- 3.2.10
- 3.2.10-RC1
- 3.2.10-RC2
- 3.2.11
- 3.2.2
- 3.2.2-RC1
- 3.2.3
- 3.2.3-RC1
- 3.2.3-RC2
- 3.2.4
- 3.2.4-RC1
- 3.2.5
- 3.2.5-RC1
- 3.2.6
- 3.2.6-RC1
- 3.2.7
- 3.2.7-RC1
- 3.2.8
- 3.2.8-RC1
- 3.2.9
- 3.2.9-RC1
- 3.3.0
- 3.3.0-RC1
- 3.3.0-b1
- 3.3.0-b2
- 3.3.1
- 3.3.1-RC1
- 3.3.10
- 3.3.10-RC1
- 3.3.2
- 3.3.2-RC1
- 3.3.3
- 3.3.3-RC1
- 3.3.4
- 3.3.4-RC1
- 3.3.5
- 3.3.5-RC1
- 3.3.6
- 3.3.6-RC1
- 3.3.7
- 3.3.8
- 3.3.8-RC1
- 3.3.9
- 3.3.9-RC1
- Affected ranges
- ECOSYSTEM: < 3.3.11
Update to 3.3.11
Original sources
- https://vuldb.com/?id.244307
- https://vuldb.com/?ctiid.244307
- https://www.phpbb.com/community/viewtopic.php?t=2646991
- https://github.com/phpbb/phpbb/commit/ccf6e6c255d38692d72fcb613b113e6eaa240aac
- https://github.com/phpbb/phpbb/releases/tag/release-3.3.11
- https://www.phpbb.com/
- https://nvd.nist.gov/vuln/detail/CVE-2023-5917