p PatchFirst

CVE-2023-6680

CVE-2023-6680 · Improper Certificate Validation in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An improper certificate validation issue in Smartcard authentication in GitLab EE affecting all versions from 11.6 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 allows an attacker to authenticate as another user given their public key if they use Smartcard authentication. Smartcard authentication is an experimental feature and has to be manually enabled by an administrator.

CVSS 7.4 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 11.6, < 16.4.4: Affected (semver)
    • ≥ 16.5, < 16.5.4: Affected (semver)
    • ≥ 16.6, < 16.6.2: Affected (semver)

    Update to 16.4.4; Update to 16.5.4; Update to 16.6.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →