CVE-2023-6935
CVE-2023-6935 · Marvin Attack vulnerability in SP Math All RSA
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wolfSSL SP Math All RSA implementation is vulnerable to the Marvin Attack, new variation of a timing Bleichenbacher style attack, when built with the following options to configure: --enable-all CFLAGS="-DWOLFSSL_STATIC_RSA" The define “WOLFSSL_STATIC_RSA” enables static RSA cipher suites, which is not recommended, and has been disabled by default since wolfSSL 3.6.6. Therefore the default build since 3.6.6, even with "--enable-all", is not vulnerable to the Marvin Attack. The vulnerability is specific to static RSA cipher suites, and expected to be padding-independent. The vulnerability allows an attacker to decrypt ciphertexts and forge signatures after probing with a large number of test observations. However the server’s private key is not exposed.
CVSS 5.9 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wolfssl
- Versions
- ≥ 3.12.2, ≤ 5.6.4: Affected (release bundle)
No fix published
wolfssl Debian:12
- Versions
- 5.5.4-2
- 5.5.4-2+deb12u1
- 5.5.4-2+deb12u2
- 5.5.4-2+deb12u3
- 5.5.4-2.1
- 5.6.4-1
- 5.6.4-2
- 5.6.6-1
- 5.6.6-1.1
- 5.6.6-1.2
- 5.6.6-1.3
- 5.6.6-1.3~exp1
- 5.7.0-0.1
- 5.7.0-0.2
- 5.7.0-0.3
- 5.7.2-0.1
- 5.7.2-0.2
- 5.7.2-0.3
- 5.7.2-0.4
- 5.8.2-1
- 5.8.2-1.1
- 5.8.2-1.2
- 5.8.4-1
- 5.9.0-0.1
- 5.9.0-0.2
- 5.9.1-0.1
- 5.9.2-1
- 5.9.2-1.1
- 5.9.2-1.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Debian:13
- Affected ranges
- ECOSYSTEM: < 5.6.6-1.2
Update to 5.6.6-1.2
wolfssl Ubuntu:16.04:LTS
- Versions
- 3.4.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:18.04:LTS
- Versions
- 3.10.2+dfsg-2
- 3.12.0+dfsg-1
- 3.12.2+dfsg-1
- 3.13.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:20.04:LTS
- Versions
- 4.1.0+dfsg-2
- 4.2.0+dfsg-1
- 4.2.0+dfsg-2
- 4.2.0+dfsg-3
- 4.3.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:22.04:LTS
- Versions
- 4.6.0-3
- 5.0.0-1
- 5.1.1-1
- 5.2.0-1
- 5.2.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published