p PatchFirst

CVE-2024-0410

CVE-2024-0410 · Improper Enforcement of Behavioral Workflow in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An authorization bypass vulnerability was discovered in GitLab affecting versions 15.1 prior to 16.7.6, 16.8 prior to 16.8.3, and 16.9 prior to 16.9.1. A developer could bypass CODEOWNERS approvals by creating a merge conflict.

CVSS 7.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.1, < 16.7.6: Affected (semver)
    • ≥ 16.8, < 16.8.3: Affected (semver)
    • ≥ 16.9, < 16.9.1: Affected (semver)

    Update to 16.7.6; Update to 16.8.3; Update to 16.9.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →