p PatchFirst

CVE-2024-0456

CVE-2024-0456 · Direct Request ('Forced Browsing') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An authorization vulnerability exists in GitLab versions 14.0 prior to 16.6.6, 16.7 prior to 16.7.4, and 16.8 prior to 16.8.1. An unauthorized attacker is able to assign arbitrary users to MRs that they created within the project

CVSS 4.3 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 14.0, < 16.6.6: Affected (semver)
    • ≥ 16.7, < 16.7.4: Affected (semver)
    • ≥ 16.8, < 16.8.1: Affected (semver)

    Update to 16.6.6; Update to 16.7.4; Update to 16.8.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →