CVE-2024-11942
CVE-2024-11942 · Drupal core - Moderately critical - Improper error handling - SA-CORE-2024-002
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in Drupal Core allows File Manipulation.This issue affects Drupal Core: from 10.0.0 before 10.2.10.
CVSS 5.9 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
drupal core
- Versions
- ≥ 10.0.0, < 10.2.10: Affected (semver)
Update to 10.2.10
drupal/core Packagist
- Versions
- 10.0.0
- 10.0.1
- 10.0.10
- 10.0.11
- 10.0.2
- 10.0.3
- 10.0.4
- 10.0.5
- 10.0.6
- 10.0.7
- 10.0.8
- 10.0.9
- 10.1.0
- 10.1.0-alpha1
- 10.1.0-beta1
- 10.1.0-rc1
- 10.1.1
- 10.1.2
- 10.1.3
- 10.1.4
- 10.1.5
- 10.1.6
- 10.1.7
- 10.1.8
- 10.2.0
- 10.2.0-alpha1
- 10.2.0-beta1
- 10.2.0-rc1
- 10.2.1
- 10.2.2
- 10.2.3
- 10.2.4
- 10.2.5
- 10.2.6
- 10.2.7
- 10.2.8
- 10.2.9
- Affected ranges
- ECOSYSTEM: ≥ 10.0.0, < 10.2.10
Update to 10.2.10
drupal/core Packagist
- Versions
- 10.0.0
- 10.0.1
- 10.0.10
- 10.0.11
- 10.0.2
- 10.0.3
- 10.0.4
- 10.0.5
- 10.0.6
- 10.0.7
- 10.0.8
- 10.0.9
- 10.1.0
- 10.1.0-alpha1
- 10.1.0-beta1
- 10.1.0-rc1
- 10.1.1
- 10.1.2
- 10.1.3
- 10.1.4
- 10.1.5
- 10.1.6
- 10.1.7
- 10.1.8
- 10.2.0
- 10.2.0-alpha1
- 10.2.0-beta1
- 10.2.0-rc1
- 10.2.1
- 10.2.2
- 10.2.3
- 10.2.4
- 10.2.5
- 10.2.6
- 10.2.7
- 10.2.8
- 10.2.9
- Affected ranges
- ECOSYSTEM: ≥ 10.0.0, < 10.2.10
Update to 10.2.10
drupal7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- 7.26-1ubuntu0.1+esm1
- 7.26-1ubuntu0.1+esm2
- 7.26-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
drupal7 Ubuntu:Pro:16.04:LTS
- Versions
- 7.38-1
- 7.41-1
- 7.44-1ubuntu1~16.04.0
- 7.44-1ubuntu1~16.04.0+esm1
- 7.44-1ubuntu1~16.04.0+esm2
- 7.44-1ubuntu1~16.04.0+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published