CVE-2024-11958
CVE-2024-11958 · SQL Injection in run-llama/llama_index
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A SQL injection vulnerability exists in the `duckdb_retriever` component of the run-llama/llama_index repository, specifically in the latest version. The vulnerability arises from the construction of SQL queries without using prepared statements, allowing an attacker to inject arbitrary SQL code. This can lead to remote code execution (RCE) by installing the shellfs extension and executing malicious commands.
CVSS 9.8 · Critical · EPSS 1.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
run-llama/llama_index
- Versions
- ≥ unspecified, < 0.4.0: Affected (custom)
Update to 0.4.0
llama-index-retrievers-duckdb-retriever PyPI
- Versions
- 0.1.4
- 0.2.0
- 0.3.0
- Affected ranges
- ECOSYSTEM: < 0.4.0
Update to 0.4.0