p PatchFirst

CVE-2024-1211

CVE-2024-1211 · Cross-Site Request Forgery (CSRF) in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.6 prior to 16.9.7, starting from 16.10 prior to 16.10.5, and starting from 16.11 prior to 16.11.2 in which cross-site request forgery may have been possible on GitLab instances configured to use JWT as an OmniAuth provider.

CVSS 6.4 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 10.6, < 16.9.7: Affected (semver)
    • ≥ 16.10, < 16.10.5: Affected (semver)
    • ≥ 16.11, < 16.11.2: Affected (semver)

    Update to 16.10.5; Update to 16.11.2; Update to 16.9.7

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →