p PatchFirst

CVE-2024-12380

CVE-2024-12380 · Generation of Error Message Containing Sensitive Information in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in GitLab EE/CE affecting all versions starting from 11.5 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2. Certain user inputs in repository mirroring settings could potentially expose sensitive authentication information.

CVSS 4.4 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 11.5, < 17.7.7: Affected (semver)
    • ≥ 17.8, < 17.8.5: Affected (semver)
    • ≥ 17.9, < 17.9.2: Affected (semver)

    Update to 17.7.7; Update to 17.8.5; Update to 17.9.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →