CVE-2024-13301
CVE-2024-13301 · OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) - Critical - Cross Site Scripting - SA-CONTRIB-2024-067
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) allows Cross-Site Scripting (XSS).This issue affects OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client): from 3.0.0 before 3.44.0, from 4.0.0 before 4.0.19.
CVSS 6.1 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
oauth & openid connect single sign on – sso (oauth/oidc client)
- Versions
- ≥ 3.0.0, < 3.44.0: Affected (semver)
- ≥ 4.0.0, < 4.0.19: Affected (semver)
Update to 3.44.0; Update to 4.0.19
drupal/miniorange_oauth_client Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: ≥ 3.32.0, < 3.44.0
- ECOSYSTEM: ≥ 4.0.1, < 4.0.19
Update to 3.44.0; Update to 4.0.19