p PatchFirst

CVE-2024-2044

CVE-2024-2044 · Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4

This page contains facts from public vulnerability sources. Check the original advisory before updating.

pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.

CVSS 9.9 · Critical · EPSS 79.5% · Public exploit · Fix available

Published
Updated

Stack: python

Affected products and versions

  • pgadmin 4

    Versions
    • ≥ 0, < 8.4: Affected (custom)

    Update to 8.4

  • pgadmin4 PyPI

    Versions
    • 4.20
    • 4.22
    • 4.23
    • 4.24
    • 4.25
    • 4.26
    • 4.27
    • 4.28
    • 4.29
    • 4.30
    • 5.0
    • 5.1
    • 5.2
    • 5.3
    • 5.4
    • 5.5
    • 5.6
    • 5.7
    • 6.10
    • 6.11
    • 6.12
    • 6.13
    • 6.14
    • 6.15
    • 6.16
    • 6.17
    • 6.18
    • 6.19
    • 6.2
    • 6.20
    • 6.21
    • 6.3
    • 6.4
    • 6.5
    • 6.6
    • 6.7
    • 6.8
    • 6.9
    • 7.0
    • 7.1
    • 7.2
    • 7.3
    • 7.4
    • 7.5
    • 7.6
    • 7.7
    • 7.8
    • 8.0
    • 8.1
    • 8.2
    • 8.3
    Affected ranges
    • ECOSYSTEM: < 8.4

    Update to 8.4

Original sources

Check your server →