CVE-2024-21386
CVE-2024-21386 · .NET Denial of Service Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
.NET Denial of Service Vulnerability
CVSS 7.5 · High · EPSS 2.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
asp.net core 6.0
- Versions
- ≥ 6.0, < 6.0.27: Affected (custom)
Update to 6.0.27
asp.net core 7.0
- Versions
- ≥ 7.0.0, < 7.0.16: Affected (custom)
Update to 7.0.16
asp.net core 8.0
- Versions
- ≥ 8.0, < 8.0.2: Affected (custom)
Update to 8.0.2
microsoft visual studio 2022 version 17.4
- Versions
- ≥ 17.4.0, < 17.4.16: Affected (custom)
Update to 17.4.16
microsoft visual studio 2022 version 17.6
- Versions
- ≥ 17.6.0, < 17.6.12: Affected (custom)
Update to 17.6.12
microsoft visual studio 2022 version 17.8
- Versions
- ≥ 17.8.0, < 17.8.7: Affected (custom)
Update to 17.8.7
dotnet6 Ubuntu:22.04:LTS
- Versions
- 6.0.108-0ubuntu1~22.04.1
- 6.0.109-0ubuntu1~22.04.1
- 6.0.110-0ubuntu1~22.04.1
- 6.0.111-0ubuntu1~22.04.1
- 6.0.113-0ubuntu1~22.04.1
- 6.0.116-0ubuntu1~22.04.1
- 6.0.118-0ubuntu1~22.04.1
- 6.0.119-0ubuntu1~22.04.1
- 6.0.120-0ubuntu1~22.04.1
- 6.0.121-0ubuntu1~22.04.1
- 6.0.122-0ubuntu1~22.04.1
- 6.0.123-0ubuntu1~22.04.1
- 6.0.124-0ubuntu1~22.04.1
- 6.0.125-0ubuntu1~22.04.1
- 6.0.126-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: < 6.0.127-0ubuntu1~22.04.1
Update to 6.0.127-0ubuntu1~22.04.1
dotnet7 Ubuntu:22.04:LTS
- Versions
- 7.0.105-0ubuntu1~22.04.1
- 7.0.107-0ubuntu1~22.04.1
- 7.0.108-0ubuntu1~22.04.1
- 7.0.109-0ubuntu1~22.04.1
- 7.0.110-0ubuntu1~22.04.1
- 7.0.111-0ubuntu1~22.04.1
- 7.0.112-0ubuntu1~22.04.1
- 7.0.113-0ubuntu1~22.04.1
- 7.0.114-0ubuntu1~22.04.1
- 7.0.115-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: < 7.0.116-0ubuntu1~22.04.1
Update to 7.0.116-0ubuntu1~22.04.1
dotnet8 Ubuntu:22.04:LTS
- Affected ranges
- ECOSYSTEM: < 8.0.102-8.0.2-0ubuntu1~22.04.1
Update to 8.0.102-8.0.2-0ubuntu1~22.04.1