CVE-2024-21484
CVE-2024-21484
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package jsrsasign before 11.0.0 are vulnerable to Observable Discrepancy via the RSA PKCS1.5 or RSAOAEP decryption process. An attacker can decrypt ciphertexts by exploiting the Marvin security flaw. Exploiting this vulnerability requires the attacker to have access to a large number of ciphertexts encrypted with the same key. Workaround The vulnerability can be mitigated by finding and replacing RSA and RSAOAEP decryption with another crypto library.
CVSS 7.5 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
jsrsasign
- Versions
- ≥ 0, < 11.0.0: Affected (semver)
Update to 11.0.0
org.webjars.npm:jsrsasign
- Versions
- ≥ 0: Affected (semver)
No fix published
org.webjars.bowergithub.kjur:jsrsasign
- Versions
- ≥ 0: Affected (semver)
No fix published
org.webjars.bower:jsrsasign
- Versions
- ≥ 0: Affected (semver)
No fix published
jsrsasign npm
- Affected ranges
- SEMVER: < 11.0.0
Update to 11.0.0
Original sources
- https://security.snyk.io/vuln/SNYK-JS-JSRSASIGN-6070731
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-6070732
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBKJUR-6070733
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-6070734
- https://github.com/kjur/jsrsasign/issues/598
- https://github.com/kjur/jsrsasign/releases/tag/11.0.0
- https://people.redhat.com/~hkario/marvin/
- https://nvd.nist.gov/vuln/detail/CVE-2024-21484