p PatchFirst

CVE-2024-21508

CVE-2024-21508

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package mysql2 before 3.9.4 are vulnerable to Remote Code Execution (RCE) via the readCodeFor function due to improper validation of the supportBigNumbers and bigNumberStrings values.

CVSS 9.8 · Critical · EPSS 2.6% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • mysql2

    Versions
    • ≥ 0, < 3.9.4: Affected (semver)

    Update to 3.9.4

  • mysql2 npm

    Affected ranges
    • SEMVER: < 3.9.4

    Update to 3.9.4

Original sources

Check your server →