CVE-2024-21539
CVE-2024-21539
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package @eslint/plugin-kit before 0.2.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by exploiting this vulnerability.
CVSS 8.7 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
@eslint/plugin-kit
- Versions
- ≥ 0, < 0.2.3: Affected (semver)
Update to 0.2.3
@eslint/plugin-kit npm
- Affected ranges
- SEMVER: < 0.2.3
Update to 0.2.3