p PatchFirst

CVE-2024-21546

CVE-2024-21546

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package unisharp/laravel-filemanager before 2.9.1 are vulnerable to Remote Code Execution (RCE) through using a valid mimetype and inserting the . character after the php file extension. This allows the attacker to execute malicious code.

CVSS 9.3 · Critical · EPSS 1.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • unisharp/laravel-filemanager

    Versions
    • ≥ 0, < 2.9.1: Affected (semver)

    Update to 2.9.1

  • unisharp/laravel-filemanager Packagist

    Versions
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 1.0.0
    • 1.1.0
    • 1.1.0-alpha
    • 1.1.1
    • 1.2.0
    • 1.3.0-alpha
    • 1.4.0-alpha
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • v1.7-alpha
    • v1.7.0
    • v1.7.1
    • v1.7.2
    • v1.7.3
    • v1.7.4
    • v1.7.5
    • v1.7.6
    • v1.7.7
    • v1.8.0
    • v1.8.1
    • v1.8.2
    • v1.8.2-alpha
    • v1.8.2.1
    • v1.8.2.2
    • v1.8.3
    • v1.8.4
    • v1.8.5
    • v1.9.0
    • v1.9.1
    • v1.9.2
    • v2.0.0
    • v2.0.0-alpha
    • v2.0.0-alpha2
    • v2.0.0-alpha3
    • v2.0.0-alpha4
    • v2.0.0-alpha5
    • v2.0.0-alpha6
    • v2.0.0-alpha7
    • v2.0.0-alpha8
    • v2.0.1
    • v2.1.0
    • v2.2.0
    • v2.3.0
    • v2.4.0
    • v2.4.1
    • v2.5.0
    • v2.5.1
    • v2.6.0
    • v2.6.1
    • v2.6.2
    • v2.6.3
    • v2.6.4
    • v2.7.0
    • v2.7.1
    • v2.8.0
    • v2.8.1
    • v2.9.0
    Affected ranges
    • ECOSYSTEM: < 2.9.1

    Update to 2.9.1

Original sources

Check your server →