p PatchFirst

CVE-2024-2177

CVE-2024-2177 · Improper Restriction of Rendered UI Layers or Frames in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A Cross Window Forgery vulnerability exists within GitLab CE/EE affecting all versions from 16.3 prior to 16.11.5, 17.0 prior to 17.0.3, and 17.1 prior to 17.1.1. This condition allows for an attacker to abuse the OAuth authentication flow via a crafted payload.

CVSS 6.8 · Medium · EPSS 0.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.3, < 16.11.5: Affected (semver)
    • ≥ 17.0, < 17.0.3: Affected (semver)
    • ≥ 17.1, < 17.1.1: Affected (semver)

    Update to 16.11.5; Update to 17.0.3; Update to 17.1.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →