CVE-2024-21891
CVE-2024-21891
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js depends on multiple built-in utility functions to normalize paths provided to node:fs functions, which can be overwitten with user-defined implementations leading to filesystem permission model bypass through path traversal attack. This vulnerability affects all users using the experimental permission model in Node.js 20 and Node.js 21. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.
CVSS 7.9 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
node.js
- Versions
- ≥ 4.0, < 4.*: Affected (semver)
- ≥ 5.0, < 5.*: Affected (semver)
- ≥ 6.0, < 6.*: Affected (semver)
- ≥ 7.0, < 7.*: Affected (semver)
- ≥ 8.0, < 8.*: Affected (semver)
- ≥ 9.0, < 9.*: Affected (semver)
- ≥ 10.0, < 10.*: Affected (semver)
- ≥ 11.0, < 11.*: Affected (semver)
- ≥ 12.0, < 12.*: Affected (semver)
- ≥ 13.0, < 13.*: Affected (semver)
- ≥ 14.0, < 14.*: Affected (semver)
- ≥ 15.0, < 15.*: Affected (semver)
- ≥ 16.0, < 16.*: Affected (semver)
- ≥ 17.0, < 17.*: Affected (semver)
- ≥ 19.0, < 19.*: Affected (semver)
- ≥ 20.0, < 20.11.1: Affected (semver)
- ≥ 21.0, < 21.6.2: Affected (semver)
Update to 20.11.1; Update to 21.6.2