CVE-2024-22258
CVE-2024-22258 · CVE-2024-22258: PKCE Downgrade in Spring Authorization Server
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.
CVSS 6.1 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
spring
- Versions
- ≥ 1.0.x, < 1.0.6: Affected (enterprise support only)
- ≥ 1.1.x, < 1.1.6: Affected (oss)
- ≥ 1.2.x , < 1.2.3: Affected (oss)
Update to 1.0.6; Update to 1.1.6
spring Ubuntu:16.04:LTS
- Versions
- 100.0+dfsg-2
- 100.0+dfsg-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:18.04:LTS
- Versions
- 103.0+dfsg2-1
- 103.0+dfsg2-1build1
- 104.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:20.04:LTS
- Versions
- 104.0+dfsg-3build2
- 104.0+dfsg-4ubuntu1
- 104.0+dfsg-4ubuntu2
- 104.0+dfsg-4ubuntu5
- 104.0+dfsg-4ubuntu6
- 104.0+dfsg-4ubuntu7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:22.04:LTS
- Versions
- 105.0.1+dfsg-2
- 105.0.1+dfsg-3ubuntu1
- 105.0.1+dfsg-3ubuntu2
- 105.0.1+dfsg-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:24.04:LTS
- Versions
- 106.0+dfsg-2
- 106.0+dfsg-3
- 106.0+dfsg-3build2
- 106.0+dfsg-3build3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:25.10
- Versions
- 106.0+dfsg-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:26.10
- Versions
- 106.0+dfsg-4
- 106.0+dfsg-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spring Ubuntu:26.04:LTS
- Versions
- 106.0+dfsg-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published