p PatchFirst

CVE-2024-22420

CVE-2024-22420 · Stored cross site scripting in Markdown Preview in JupyterLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. This vulnerability depends on user interaction by opening a malicious Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab version 4.0.11 has been patched. Users are advised to upgrade. Users unable to upgrade should disable the table of contents extension.

CVSS 6.5 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • jupyterlab

    Versions
    • >=4.0.0, < 4.0.11: Affected

    No fix published

  • jupyterlab Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.0.11+ds1-1

    Update to 4.0.11+ds1-1

  • jupyterlab Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.0.11+ds1-1

    Update to 4.0.11+ds1-1

  • jupyterlab PyPI

    Versions
    • 4.0.0
    • 4.0.1
    • 4.0.10
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.0.7
    • 4.0.8
    • 4.0.9
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.11

    Update to 4.0.11

  • notebook PyPI

    Versions
    • 7.0.0
    • 7.0.1
    • 7.0.2
    • 7.0.3
    • 7.0.4
    • 7.0.5
    • 7.0.6
    Affected ranges
    • ECOSYSTEM: ≥ 7.0.0, < 7.0.7

    Update to 7.0.7

Original sources

Check your server →