CVE-2024-22682
CVE-2024-22682 · PYSEC-2024-25
This page contains facts from public vulnerability sources. Check the original advisory before updating.
DuckDB <=0.9.2 and DuckDB extension-template <=0.9.2 are vulnerable to malicious extension injection via the custom extension feature.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: python
Affected products and versions
duckdb PyPI
- Versions
- 0.0.0
- 0.0.2
- 0.0.3
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.4.0
- 0.5.0
- 0.5.1
- 0.6.0
- 0.6.1
- 0.7.0
- 0.7.1
- 0.8.0
- 0.8.1
- 0.9.0
- 0.9.1
- 0.9.2
- Affected ranges
- ECOSYSTEM: < 0.9.3.dev6
Update to 0.9.3.dev6