CVE-2024-23117
CVE-2024-23117 · Centreon updateContactServiceCommands SQL Injection Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Centreon updateContactServiceCommands SQL Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Centreon. Authentication is required to exploit this vulnerability. The specific flaw exists within the updateContactServiceCommands function. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-22297.
CVSS 7.2 · High · EPSS 53.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
centreon
- Versions
- 23.10.0: Affected
No fix published
centreon/centreon Packagist
- Affected ranges
- ECOSYSTEM: < 22.10.15
Update to 22.10.15