CVE-2024-23450
CVE-2024-23450 · Elasticsearch Uncontrolled Resource Consumption vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was discovered in Elasticsearch, where processing a document in a deeply nested pipeline on an ingest node could cause the Elasticsearch node to crash.
CVSS 4.9 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
elasticsearch
- Versions
- ≥ 7.0.0, < 7.17.19: Affected (semver)
- ≥ 8.0.0, < 8.13.0: Affected (semver)
Update to 7.17.19; Update to 8.13.0
elasticsearch Ubuntu:16.04:LTS
- Versions
- 1.6.2+dfsg-1
- 1.7.3+dfsg-1
- 1.7.3+dfsg-2
- 1.7.3+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published