CVE-2024-24574
CVE-2024-24574 · phpMyFAQ vulnerable to stored XSS on attachments filename
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.
CVSS 6.5 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
phpmyfaq
- Versions
- < 3.2.5: Affected
No fix published
phpmyfaq/phpmyfaq Packagist
- Versions
- 2.10.0-alpha
- 2.8.0
- 2.8.0-RC
- 2.8.0-RC2
- 2.8.0-RC3
- 2.8.0-RC4
- 2.8.0-alpha2
- 2.8.0-alpha3
- 2.8.0-beta
- 2.8.0-beta2
- 2.8.0-beta3
- 2.8.1
- 2.8.10
- 2.8.11
- 2.8.12
- 2.8.13
- 2.8.14
- 2.8.15
- 2.8.16
- 2.8.17
- 2.8.18
- 2.8.19
- 2.8.2
- 2.8.20
- 2.8.21
- 2.8.22
- 2.8.23
- 2.8.24
- 2.8.25
- 2.8.26
- 2.8.27
- 2.8.28
- 2.8.29
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.8.9
- 2.9.0
- 2.9.0-alpha
- 2.9.0-alpha2
- 2.9.0-alpha3
- 2.9.0-alpha4
- 2.9.0-beta
- 2.9.0-beta2
- 2.9.0-rc
- 2.9.0-rc2
- 2.9.0-rc3
- 2.9.0-rc4
- 2.9.1
- 2.9.10
- 2.9.11
- 2.9.12
- 2.9.13
- 2.9.2
- 2.9.3
- 2.9.4
- 2.9.5
- 2.9.6
- 2.9.7
- 2.9.8
- 2.9.9
- 3.0.0
- 3.0.0-RC
- 3.0.0-RC.2
- 3.0.0-alpha
- 3.0.0-alpha.2
- 3.0.0-alpha.3
- 3.0.0-alpha.4
- 3.0.0-beta
- 3.0.0-beta.2
- 3.0.0-beta.3
- 3.0.1
- 3.0.10
- 3.0.11
- 3.0.12
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.0.6
- 3.0.7
- 3.0.8
- 3.0.9
- 3.1.0
- 3.1.0-RC
- 3.1.0-alpha
- 3.1.0-alpha.2
- 3.1.0-alpha.3
- 3.1.0-beta
- 3.1.1
- 3.1.10
- 3.1.11
- 3.1.12
- 3.1.13
- 3.1.14
- 3.1.15
- 3.1.16
- 3.1.17
- 3.1.18
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.5
- 3.1.6
- 3.1.7
- 3.1.8
- 3.1.9
- 3.2.0
- 3.2.0-RC
- 3.2.0-RC.2
- 3.2.0-RC.4
- 3.2.0-alpha
- 3.2.0-beta
- 3.2.0-beta.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- Affected ranges
- ECOSYSTEM: < 3.2.5
Update to 3.2.5