p PatchFirst

CVE-2024-24773

CVE-2024-24773 · Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

CVSS 4.9 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache superset

    Versions
    • ≥ 0, < 3.0.4: Affected (semver)
    • ≥ 3.1.0, < 3.1.1: Affected (semver)

    Update to 3.0.4; Update to 3.1.1

  • apache-superset PyPI

    Versions
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    Affected ranges
    • ECOSYSTEM: < 3.0.4

    Update to 3.0.4

  • apache-superset PyPI

    Versions
    • 3.1.0
    Affected ranges
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.1

    Update to 3.1.1

  • apache-superset PyPI

    Versions
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.0
    Affected ranges
    • ECOSYSTEM: < 3.0.4 ∪ ≥ 3.1.0, < 3.1.1

    Update to 3.0.4; Update to 3.1.1

Original sources

Check your server →