CVE-2024-2494
CVE-2024-2494 · Libvirt: negative g_new0 length can lead to unbounded memory allocation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in the RPC library APIs of libvirt. The RPC server deserialization code allocates memory for arrays before the non-negative length check is performed by the C API entry points. Passing a negative length to the g_new0 function results in a crash due to the negative length being treated as a huge positive number. This flaw allows a local, unprivileged user to perform a denial of service attack by causing the libvirt daemon to crash.
CVSS 6.2 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat enterprise linux 8
- Versions
- ≥ 8100020240409073027.489197e6: Not affected (rpm)
No fix published
red hat enterprise linux 9
- Versions
- ≥ 0:10.0.0-6.2.el9_4: Not affected (rpm)
No fix published
red hat enterprise linux 6
No fix published
red hat enterprise linux 7
No fix published
red hat enterprise linux 8 advanced virtualization
No fix published
libvirt Debian:12
- Versions
- 9.0.0-4
- Affected ranges
- ECOSYSTEM: < 9.0.0-4+deb12u1
Update to 9.0.0-4+deb12u1
libvirt Debian:13
- Affected ranges
- ECOSYSTEM: < 10.2.0-1
Update to 10.2.0-1
libvirt Debian:14
- Affected ranges
- ECOSYSTEM: < 10.2.0-1
Update to 10.2.0-1
libvirt Ubuntu:Pro:14.04:LTS
- Versions
- 1.1.1-0ubuntu8
- 1.1.1-0ubuntu9
- 1.1.4-0ubuntu2
- 1.1.4-0ubuntu3
- 1.1.4-0ubuntu4
- 1.1.4-0ubuntu5
- 1.2.0-0ubuntu1
- 1.2.0-0ubuntu2
- 1.2.0-0ubuntu3
- 1.2.1-0ubuntu1
- 1.2.1-0ubuntu2
- 1.2.1-0ubuntu3
- 1.2.1-0ubuntu4
- 1.2.1-0ubuntu5
- 1.2.1-0ubuntu7
- 1.2.1-0ubuntu8
- 1.2.1-0ubuntu9
- 1.2.1-0ubuntu10
- 1.2.2-0ubuntu1
- 1.2.2-0ubuntu2
- 1.2.2-0ubuntu3
- 1.2.2-0ubuntu4
- 1.2.2-0ubuntu5
- 1.2.2-0ubuntu6
- 1.2.2-0ubuntu7
- 1.2.2-0ubuntu8
- 1.2.2-0ubuntu9
- 1.2.2-0ubuntu10
- 1.2.2-0ubuntu11
- 1.2.2-0ubuntu12
- 1.2.2-0ubuntu13
- 1.2.2-0ubuntu13.1
- 1.2.2-0ubuntu13.1.1
- 1.2.2-0ubuntu13.1.2
- 1.2.2-0ubuntu13.1.4
- 1.2.2-0ubuntu13.1.5
- 1.2.2-0ubuntu13.1.6
- 1.2.2-0ubuntu13.1.7
- 1.2.2-0ubuntu13.1.8
- 1.2.2-0ubuntu13.1.9
- 1.2.2-0ubuntu13.1.10
- 1.2.2-0ubuntu13.1.12
- 1.2.2-0ubuntu13.1.14
- 1.2.2-0ubuntu13.1.16
- 1.2.2-0ubuntu13.1.17
- 1.2.2-0ubuntu13.1.20
- 1.2.2-0ubuntu13.1.21
- 1.2.2-0ubuntu13.1.22
- 1.2.2-0ubuntu13.1.23
- 1.2.2-0ubuntu13.1.25
- 1.2.2-0ubuntu13.1.26
- 1.2.2-0ubuntu13.1.27
- 1.2.2-0ubuntu13.1.28
- 1.2.2-0ubuntu13.1.28+esm1
- Affected ranges
- ECOSYSTEM: < 1.2.2-0ubuntu13.1.28+esm2
Update to 1.2.2-0ubuntu13.1.28+esm2
libvirt Ubuntu:Pro:16.04:LTS
- Versions
- 1.2.16-2ubuntu11
- 1.2.16-2ubuntu12
- 1.2.16-2ubuntu13
- 1.2.16-2ubuntu14
- 1.2.21-2ubuntu1
- 1.2.21-2ubuntu3
- 1.2.21-2ubuntu4
- 1.2.21-2ubuntu5
- 1.2.21-2ubuntu7
- 1.2.21-2ubuntu8
- 1.2.21-2ubuntu9
- 1.2.21-2ubuntu10
- 1.3.1-1ubuntu1
- 1.3.1-1ubuntu2
- 1.3.1-1ubuntu3
- 1.3.1-1ubuntu4
- 1.3.1-1ubuntu6
- 1.3.1-1ubuntu9
- 1.3.1-1ubuntu10
- 1.3.1-1ubuntu10.1
- 1.3.1-1ubuntu10.2
- 1.3.1-1ubuntu10.3
- 1.3.1-1ubuntu10.5
- 1.3.1-1ubuntu10.6
- 1.3.1-1ubuntu10.7
- 1.3.1-1ubuntu10.8
- 1.3.1-1ubuntu10.10
- 1.3.1-1ubuntu10.11
- 1.3.1-1ubuntu10.12
- 1.3.1-1ubuntu10.13
- 1.3.1-1ubuntu10.14
- 1.3.1-1ubuntu10.15
- 1.3.1-1ubuntu10.17
- 1.3.1-1ubuntu10.18
- 1.3.1-1ubuntu10.19
- 1.3.1-1ubuntu10.21
- 1.3.1-1ubuntu10.22
- 1.3.1-1ubuntu10.23
- 1.3.1-1ubuntu10.24
- 1.3.1-1ubuntu10.25
- 1.3.1-1ubuntu10.26
- 1.3.1-1ubuntu10.27
- 1.3.1-1ubuntu10.29
- 1.3.1-1ubuntu10.30
- 1.3.1-1ubuntu10.31
- Affected ranges
- ECOSYSTEM: < 1.3.1-1ubuntu10.31+esm1
Update to 1.3.1-1ubuntu10.31+esm1
libvirt Ubuntu:Pro:18.04:LTS
- Versions
- 3.6.0-1ubuntu5
- 3.6.0-1ubuntu6
- 4.0.0-1ubuntu1
- 4.0.0-1ubuntu2
- 4.0.0-1ubuntu3
- 4.0.0-1ubuntu4
- 4.0.0-1ubuntu5
- 4.0.0-1ubuntu6
- 4.0.0-1ubuntu7
- 4.0.0-1ubuntu8
- 4.0.0-1ubuntu8.1
- 4.0.0-1ubuntu8.2
- 4.0.0-1ubuntu8.3
- 4.0.0-1ubuntu8.4
- 4.0.0-1ubuntu8.5
- 4.0.0-1ubuntu8.6
- 4.0.0-1ubuntu8.7
- 4.0.0-1ubuntu8.8
- 4.0.0-1ubuntu8.9
- 4.0.0-1ubuntu8.10
- 4.0.0-1ubuntu8.11
- 4.0.0-1ubuntu8.12
- 4.0.0-1ubuntu8.13
- 4.0.0-1ubuntu8.14
- 4.0.0-1ubuntu8.15
- 4.0.0-1ubuntu8.16
- 4.0.0-1ubuntu8.17
- 4.0.0-1ubuntu8.19
- 4.0.0-1ubuntu8.20
- 4.0.0-1ubuntu8.21
- Affected ranges
- ECOSYSTEM: < 4.0.0-1ubuntu8.21+esm1
Update to 4.0.0-1ubuntu8.21+esm1
libvirt Ubuntu:20.04:LTS
- Versions
- 5.4.0-0ubuntu5
- 6.0.0-0ubuntu1
- 6.0.0-0ubuntu2
- 6.0.0-0ubuntu3
- 6.0.0-0ubuntu4
- 6.0.0-0ubuntu5
- 6.0.0-0ubuntu6
- 6.0.0-0ubuntu7
- 6.0.0-0ubuntu8
- 6.0.0-0ubuntu8.1
- 6.0.0-0ubuntu8.2
- 6.0.0-0ubuntu8.3
- 6.0.0-0ubuntu8.4
- 6.0.0-0ubuntu8.5
- 6.0.0-0ubuntu8.7
- 6.0.0-0ubuntu8.8
- 6.0.0-0ubuntu8.9
- 6.0.0-0ubuntu8.10
- 6.0.0-0ubuntu8.11
- 6.0.0-0ubuntu8.12
- 6.0.0-0ubuntu8.13
- 6.0.0-0ubuntu8.14
- 6.0.0-0ubuntu8.15
- 6.0.0-0ubuntu8.16
- Affected ranges
- ECOSYSTEM: < 6.0.0-0ubuntu8.19
Update to 6.0.0-0ubuntu8.19
libvirt Ubuntu:22.04:LTS
- Versions
- 7.6.0-0ubuntu1
- 7.6.0-0ubuntu3
- 8.0.0-1ubuntu3
- 8.0.0-1ubuntu4
- 8.0.0-1ubuntu5
- 8.0.0-1ubuntu6
- 8.0.0-1ubuntu7
- 8.0.0-1ubuntu7.1
- 8.0.0-1ubuntu7.2
- 8.0.0-1ubuntu7.3
- 8.0.0-1ubuntu7.4
- 8.0.0-1ubuntu7.5
- 8.0.0-1ubuntu7.6
- 8.0.0-1ubuntu7.7
- 8.0.0-1ubuntu7.8
- 8.0.0-1ubuntu7.9
- Affected ranges
- ECOSYSTEM: < 8.0.0-1ubuntu7.10
Update to 8.0.0-1ubuntu7.10
libvirt Ubuntu:24.04:LTS
- Versions
- 9.6.0-1ubuntu1
- 9.6.0-1ubuntu2
- 10.0.0-1ubuntu1
- 10.0.0-2ubuntu1
- 10.0.0-2ubuntu5
- 10.0.0-2ubuntu7
- 10.0.0-2ubuntu8
- Affected ranges
- ECOSYSTEM: < 10.0.0-2ubuntu8.1
Update to 10.0.0-2ubuntu8.1
Original sources
- https://access.redhat.com/errata/RHSA-2024:2560
- https://access.redhat.com/errata/RHSA-2024:3253
- https://access.redhat.com/security/cve/CVE-2024-2494
- https://bugzilla.redhat.com/show_bug.cgi?id=2270115
- https://lists.libvirt.org/archives/list/[email protected]/thread/BKRQXPLPC6B7FLHJXSBQYW7HNDEBW6RJ/
- https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html
- https://security.netapp.com/advisory/ntap-20240517-0009/
- https://nvd.nist.gov/vuln/detail/CVE-2024-2494