p PatchFirst

CVE-2024-25108

CVE-2024-25108 · Insufficient authorization allowing elevated access to resources in pixelfed

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Pixelfed is an open source photo sharing platform. When processing requests authorization was improperly and insufficiently checked, allowing attackers to access far more functionality than users intended, including to the administrative and moderator functionality of the Pixelfed server. This vulnerability affects every version of Pixelfed between v0.10.4 and v0.11.9, inclusive. A proof of concept of this vulnerability exists. This vulnerability affects every local user of a Pixelfed server, and can potentially affect the servers' ability to federate. Some user interaction is required to setup the conditions to be able to exercise the vulnerability, but the attacker could conduct this attack time-delayed manner, where user interaction is not actively required. This vulnerability has been addressed in version 0.11.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 9.9 · Critical · EPSS 0.7% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • pixelfed

    Versions
    • >= 0.10.4, < 0.11.11: Affected

    No fix published

  • pixelfed/pixelfed Packagist

    Versions
    • v0.10.10
    • v0.10.4
    • v0.10.5
    • v0.10.6
    • v0.10.7
    • v0.10.8
    • v0.10.9
    • v0.11.0
    • v0.11.1
    • v0.11.10
    • v0.11.2
    • v0.11.3
    • v0.11.4
    • v0.11.5
    • v0.11.6
    • v0.11.7
    • v0.11.8
    • v0.11.9
    Affected ranges
    • ECOSYSTEM: ≥ 0.10.4, < 0.11.11

    Update to 0.11.11

Original sources

Check your server →