p PatchFirst

CVE-2024-25112

CVE-2024-25112 · Denial of service due to unbounded recursion in QuickTimeVideo::multipleEntriesDecoder in Exiv2

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A denial-of-service was found in Exiv2 version v0.28.1: an unbounded recursion can cause Exiv2 to crash by exhausting the stack. The vulnerable function, `QuickTimeVideo::multipleEntriesDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted video file. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 5.5 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • exiv2

    Versions
    • >= 0.28.0 < 0.28.2: Affected

    No fix published

  • exiv2 Debian:12

    Versions
    • 0.27.6-1
    • 0.28.0+dfsg-1
    • 0.28.0+dfsg-2
    • 0.28.0+dfsg-3
    • 0.28.0+dfsg-4
    • 0.28.1+dfsg-1
    • 0.28.1+dfsg-2
    • 0.28.1+dfsg-3
    • 0.28.2+dfsg-1
    • 0.28.3+dfsg-1
    • 0.28.3+dfsg-2
    • 0.28.4+dfsg-1
    • 0.28.4+dfsg-2
    • 0.28.5+dfsg-1
    • 0.28.7+dfsg-1
    • 0.28.7+dfsg-2
    • 0.28.8+dfsg-1
    • 0.28.9+dfsg-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • exiv2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.28.3+dfsg-2

    Update to 0.28.3+dfsg-2

  • exiv2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.28.3+dfsg-2

    Update to 0.28.3+dfsg-2

  • exiv2 PyPI

    Versions
    • 0.16.0
    Affected ranges
    • ECOSYSTEM: ≥ 0.16.0, < 0.16.1

    Update to 0.16.1

Original sources

Check your server →