CVE-2024-28102
CVE-2024-28102 · JWCrypto vulnerable to JWT bomb Attack in `deserialize` function
This page contains facts from public vulnerability sources. Check the original advisory before updating.
JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to version 1.5.6, an attacker can cause a denial of service attack by passing in a malicious JWE Token with a high compression ratio. When the server processes this token, it will consume a lot of memory and processing time. Version 1.5.6 fixes this vulnerability by limiting the maximum token length.
CVSS 6.8 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
jwcrypto
- Versions
- < 1.5.6: Affected
No fix published
python-jwcrypto Debian:12
- Versions
- 1.1.0-1
- Affected ranges
- ECOSYSTEM: < 1.1.0-1+deb12u1
Update to 1.1.0-1+deb12u1
python-jwcrypto Debian:13
- Affected ranges
- ECOSYSTEM: < 1.5.6-1
Update to 1.5.6-1
python-jwcrypto Debian:14
- Affected ranges
- ECOSYSTEM: < 1.5.6-1
Update to 1.5.6-1
jwcrypto PyPI
- Versions
- 0.2.0
- 0.2.1
- 0.3.0
- 0.3.1
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.6.0
- 0.7
- 0.8
- 0.9
- 0.9.1
- 1.0
- 1.2
- 1.3
- 1.3.1
- 1.4
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- Affected ranges
- ECOSYSTEM: < 1.5.6
Update to 1.5.6
python-jwcrypto Ubuntu:16.04:LTS
- Versions
- 0.2.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:18.04:LTS
- Versions
- 0.3.2-1
- 0.4.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:20.04:LTS
- Versions
- 0.6.0-1
- 0.6.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:22.04:LTS
- Versions
- 0.8.0-1
- 1.0.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:24.04:LTS
- Versions
- 1.1.0-1
- 1.5.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:25.10
- Versions
- 1.5.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:26.10
- Versions
- 1.5.6-1
- 1.5.6-1.1
- 1.5.6-1.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
python-jwcrypto Ubuntu:26.04:LTS
- Versions
- 1.5.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/latchset/jwcrypto/security/advisories/GHSA-j857-7rvv-vj97
- https://github.com/latchset/jwcrypto/commit/90477a3b6e73da69740e00b8161f53fea19b831f
- https://www.vicarius.io/vsociety/posts/denial-of-service-vulnerability-discovered-in-jwcrypto-cve-2024-28102-28103
- https://lists.debian.org/debian-lts-announce/2024/09/msg00026.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-28102