CVE-2024-28179
CVE-2024-28179 · Jupyter Server Proxy's Websocket Proxying does not require authentication
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Jupyter Server Proxy allows users to run arbitrary external processes alongside their Jupyter notebook servers and provides authenticated web access. Prior to versions 3.2.3 and 4.1.1, Jupyter Server Proxy did not check user authentication appropriately when proxying websockets, allowing unauthenticated access to anyone who had network access to the Jupyter server endpoint. This vulnerability can allow unauthenticated remote access to any websocket endpoint set up to be accessible via Jupyter Server Proxy. In many cases, this leads to remote unauthenticated arbitrary code execution, due to how affected instances use websockets. The websocket endpoints exposed by `jupyter_server` itself is not affected. Projects that do not rely on websockets are also not affected. Versions 3.2.3 and 4.1.1 contain a fix for this issue.
CVSS 9.1 · Critical · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
jupyter-server-proxy
- Versions
- >= 4.0.0, < 4.1.1: Affected
- < 3.2.3: Affected
No fix published
jupyter-server-proxy PyPI
- Versions
- 4.0.0
- 4.1.0
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.1.1
Update to 4.1.1
jupyter-server-proxy PyPI
- Versions
- 1.0
- 1.0.1
- 1.0b1
- 1.0b2
- 1.0b4
- 1.0b5
- 1.0b6
- 1.0b7
- 1.0b8
- 1.0b9
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.5.0
- 1.5.2
- 1.5.3
- 1.6.0
- 3.0.0
- 3.0.0rc1
- 3.0.1
- 3.0.2
- 3.1.0
- 3.2.0
- 3.2.1
- 3.2.2
- Affected ranges
- ECOSYSTEM: < 3.2.3
Update to 3.2.3
jupyter-server-proxy PyPI
- Versions
- 1.0
- 1.0.1
- 1.0b1
- 1.0b2
- 1.0b4
- 1.0b5
- 1.0b6
- 1.0b7
- 1.0b8
- 1.0b9
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.5.0
- 1.5.2
- 1.5.3
- 1.6.0
- 3.0.0
- 3.0.0rc1
- 3.0.1
- 3.0.2
- 3.1.0
- 3.2.0
- 3.2.1
- 3.2.2
- 4.0.0
- 4.1.0
- v3.2.2
- v4.1.0
- v4.0.0
- v3.2.1
- v3.2.0
- v3.0.2
- v3.0.1
- v3.0.0
- v3.0.0-rc.1
- v1.6.0
- v1.5.3
- v1.5.2
- v1.5.0
- v1.4.0
- v1.3.2
- v1.3.1
- v1.3.0
- v1.1.0
- v1.0.1
- v0.8.8
- v0.8.7
- v0.8.6
- v0.8.5
- v0.8.4
- v0.8.3
- v0.8.2
- v0.8.1
- v0.8.0
- v0.7.0
- v0.5.0
- v0.3.2
- v0.3.1
- v0.3.0
- v0.2.0
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "764e499f61a87641916a7a427d4c4b1ac3f321a9"}, {"fixed": "bead903b7c0354b6efd8b4cde94b89afab653e03"}], "repo": "https://github.com/jupyterhub/jupyter-server-proxy", "type": "GIT"}
- ECOSYSTEM: < 3.2.3 ∪ ≥ 4.0.0, < 4.1.1
Update to 3.2.3; Update to 4.1.1
Original sources
- https://github.com/jupyterhub/jupyter-server-proxy/security/advisories/GHSA-w3vc-fx9p-wp4v
- https://github.com/jupyterhub/jupyter-server-proxy/commit/764e499f61a87641916a7a427d4c4b1ac3f321a9
- https://github.com/jupyterhub/jupyter-server-proxy/commit/bead903b7c0354b6efd8b4cde94b89afab653e03
- https://github.com/jupyterhub/jupyter-server-proxy/blob/9b624c4d9507176334b46a85d94a4aa3bcd29bed/jupyter_server_proxy/handlers.py#L433
- https://nvd.nist.gov/vuln/detail/CVE-2024-28179