p PatchFirst

CVE-2024-28849

CVE-2024-28849 · Proxy-Authorization header kept across hosts in follow-redirects

This page contains facts from public vulnerability sources. Check the original advisory before updating.

follow-redirects is an open source, drop-in replacement for Node's `http` and `https` modules that automatically follows redirects. In affected versions follow-redirects only clears authorization header during cross-domain redirect, but keep the proxy-authentication header which contains credentials too. This vulnerability may lead to credentials leak, but has been addressed in version 1.15.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 6.5 · Medium · EPSS 1.0% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • follow-redirects

    Versions
    • < 1.15.6: Affected

    No fix published

  • node-follow-redirects Debian:12

    Versions
    • 1.15.11+~1.14.4-1
    • 1.15.11+~1.14.4-2
    • 1.15.2+~1.14.1-1
    • 1.15.3+~1.14.2-1
    • 1.15.6+~1.14.4-1
    • 1.15.6+~1.14.4-2
    • 1.15.9+~1.14.4-1
    • 1.16.0+~1.14.4-1
    • 1.16.0+~1.14.4-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-follow-redirects Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.15.6+~1.14.4-1

    Update to 1.15.6+~1.14.4-1

  • node-follow-redirects Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.15.6+~1.14.4-1

    Update to 1.15.6+~1.14.4-1

  • follow-redirects npm

    Affected ranges
    • SEMVER: < 1.15.6

    Update to 1.15.6

  • node-follow-redirects Ubuntu:Pro:18.04:LTS

    Versions
    • 1.2.4-1
    Affected ranges
    • ECOSYSTEM: < 1.2.4-1ubuntu0.18.04.1~esm1

    Update to 1.2.4-1ubuntu0.18.04.1~esm1

  • node-follow-redirects Ubuntu:Pro:20.04:LTS

    Versions
    • 1.2.4-1
    Affected ranges
    • ECOSYSTEM: < 1.2.4-1ubuntu0.20.04.1~esm1

    Update to 1.2.4-1ubuntu0.20.04.1~esm1

  • node-follow-redirects Ubuntu:Pro:22.04:LTS

    Versions
    • 1.13.1-1
    • 1.14.5-1
    • 1.14.7+~1.13.1-1
    • 1.14.8+~1.14.0-1
    • 1.14.9+~1.14.1-1
    Affected ranges
    • ECOSYSTEM: < 1.14.9+~1.14.1-1ubuntu0.1~esm1

    Update to 1.14.9+~1.14.1-1ubuntu0.1~esm1

Original sources

Check your server →