p PatchFirst

CVE-2024-29511

CVE-2024-29511

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Artifex Ghostscript before 10.03.1, when Tesseract is used for OCR, has a directory traversal issue that allows arbitrary file reading (and writing of error messages to arbitrary files) via OCRLanguage. For example, exploitation can use debug_file /tmp/out and user_patterns_file /etc/passwd.

CVSS 7.5 · High · EPSS 1.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Versions
    • 10.0.0~dfsg-11
    • 10.0.0~dfsg-11+deb12u1
    • 10.0.0~dfsg-11+deb12u2
    • 10.0.0~dfsg-11+deb12u3
    • 10.0.0~dfsg-11+deb12u4
    • 10.0.0~dfsg-11+deb12u5
    • 10.0.0~dfsg-11+deb12u6
    • 10.0.0~dfsg-11+deb12u7
    • 10.0.0~dfsg-11+deb12u8
    • 10.01.2~dfsg-1
    • 10.02.0~dfsg-1
    • 10.02.0~dfsg-2
    • 10.02.1~dfsg-1
    • 10.02.1~dfsg-2
    • 10.02.1~dfsg-3
    • 10.03.0~dfsg-1
    • 10.03.1~dfsg-1
    • 10.03.1~dfsg-2
    • 10.03.1~dfsg~git20240518-1
    • 10.04.0~dfsg-1
    • 10.04.0~dfsg-2
    • 10.05.0~dfsg-1
    • 10.05.1~dfsg-1
    • 10.05.1~dfsg-2
    • 10.05.1~dfsg-3
    • 10.06.0~dfsg-1
    • 10.06.0~dfsg-2
    • 10.06.0~dfsg-3
    • 10.07.0~dfsg-1
    • 10.07.0~dfsg-2
    • 10.07.1~dfsg-1
    • 10.08.0~dfsg-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 10.03.0~dfsg-1

    Update to 10.03.0~dfsg-1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 10.03.0~dfsg-1

    Update to 10.03.0~dfsg-1

  • ghostscript Ubuntu:22.04:LTS

    Versions
    • 9.54.0~dfsg1-0ubuntu2
    • 9.55.0~dfsg1-0ubuntu4
    • 9.55.0~dfsg1-0ubuntu5
    • 9.55.0~dfsg1-0ubuntu5.1
    • 9.55.0~dfsg1-0ubuntu5.2
    • 9.55.0~dfsg1-0ubuntu5.3
    • 9.55.0~dfsg1-0ubuntu5.4
    • 9.55.0~dfsg1-0ubuntu5.5
    • 9.55.0~dfsg1-0ubuntu5.6
    • 9.55.0~dfsg1-0ubuntu5.7
    Affected ranges
    • ECOSYSTEM: < 9.55.0~dfsg1-0ubuntu5.9

    Update to 9.55.0~dfsg1-0ubuntu5.9

  • ghostscript Ubuntu:24.04:LTS

    Versions
    • 10.01.2~dfsg1-0ubuntu2
    • 10.01.2~dfsg1-0ubuntu2.1
    • 10.02.1~dfsg1-0ubuntu1
    • 10.02.1~dfsg1-0ubuntu2
    • 10.02.1~dfsg1-0ubuntu5
    • 10.02.1~dfsg1-0ubuntu6
    • 10.02.1~dfsg1-0ubuntu7
    • 10.02.1~dfsg1-0ubuntu7.1
    Affected ranges
    • ECOSYSTEM: < 10.02.1~dfsg1-0ubuntu7.3

    Update to 10.02.1~dfsg1-0ubuntu7.3

Original sources

Check your server →