CVE-2024-30105
CVE-2024-30105 · .NET and Visual Studio Denial of Service Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
.NET and Visual Studio Denial of Service Vulnerability
CVSS 7.5 · High · EPSS 2.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
.net 8.0
- Versions
- ≥ 8.0, < 8.0.7: Affected (custom)
Update to 8.0.7
powershell 7.4
- Versions
- ≥ 7.4.0, < 7.4.4: Affected (custom)
Update to 7.4.4
microsoft visual studio 2022 version 17.4
- Versions
- ≥ 17.4.0, < 17.4.21: Affected (custom)
Update to 17.4.21
microsoft visual studio 2022 version 17.6
- Versions
- ≥ 17.6.0, < 17.6.17: Affected (custom)
Update to 17.6.17
microsoft visual studio 2022 version 17.10
- Versions
- ≥ 17.10, < 17.10.4: Affected (custom)
Update to 17.10.4
microsoft visual studio 2022 version 17.8
- Versions
- ≥ 17.8.0, < 17.8.12: Affected (custom)
Update to 17.8.12
dotnet7 Ubuntu:22.04:LTS
- Versions
- 7.0.105-0ubuntu1~22.04.1
- 7.0.107-0ubuntu1~22.04.1
- 7.0.108-0ubuntu1~22.04.1
- 7.0.109-0ubuntu1~22.04.1
- 7.0.110-0ubuntu1~22.04.1
- 7.0.111-0ubuntu1~22.04.1
- 7.0.112-0ubuntu1~22.04.1
- 7.0.113-0ubuntu1~22.04.1
- 7.0.114-0ubuntu1~22.04.1
- 7.0.115-0ubuntu1~22.04.1
- 7.0.116-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.2
- 7.0.119-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
dotnet8 Ubuntu:22.04:LTS
- Versions
- 8.0.102-8.0.2-0ubuntu1~22.04.1
- 8.0.103-8.0.3-0ubuntu1~22.04.1
- 8.0.103-8.0.3-0ubuntu1~22.04.2
- 8.0.105-8.0.5-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: < 8.0.107-8.0.7-0ubuntu1~22.04.1
Update to 8.0.107-8.0.7-0ubuntu1~22.04.1
dotnet8 Ubuntu:24.04:LTS
- Versions
- 8.0.100-8.0.0~rc1-0ubuntu1
- 8.0.100-8.0.0~rc2-0ubuntu1
- 8.0.100-8.0.0~rc2-0ubuntu2
- 8.0.100-8.0.0-0ubuntu1
- 8.0.100-8.0.0-0ubuntu2
- 8.0.101-8.0.1-0ubuntu1
- 8.0.101-8.0.1-0ubuntu2
- 8.0.102-8.0.2-0ubuntu1
- 8.0.103-8.0.3-0ubuntu2
- 8.0.103-8.0.3-0ubuntu3
- 8.0.104-8.0.4-0ubuntu1
- 8.0.105-8.0.5-0ubuntu1~24.04.1
- Affected ranges
- ECOSYSTEM: < 8.0.107-8.0.7-0ubuntu1~24.04.1
Update to 8.0.107-8.0.7-0ubuntu1~24.04.1