CVE-2024-3098
CVE-2024-3098 · Prompt Injection leading to Arbitrary Code Execution in run-llama/llama_index
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was identified in the `exec_utils` class of the `llama_index` package, specifically within the `safe_eval` function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.
CVSS 9.8 · Critical · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
run-llama/llama_index
- Versions
- ≥ unspecified, < 0.10.24: Affected (custom)
Update to 0.10.24
llama-index-core PyPI
- Versions
- 0.10.0
- 0.10.1
- 0.10.10
- 0.10.11
- 0.10.11.post1
- 0.10.12
- 0.10.13
- 0.10.14
- 0.10.14.post1
- 0.10.15
- 0.10.16
- 0.10.16.post1
- 0.10.17
- 0.10.18
- 0.10.18.post1
- 0.10.19
- 0.10.2
- 0.10.20
- 0.10.20.post1
- 0.10.20.post2
- 0.10.20.post3
- 0.10.21
- 0.10.21.post1
- 0.10.22
- 0.10.23
- 0.10.23.post1
- 0.10.24a1
- 0.10.3
- 0.10.5
- 0.10.5a1
- 0.10.5a10
- 0.10.5a2
- 0.10.5a3
- 0.10.5a4
- 0.10.5a5
- 0.10.5a6
- 0.10.5a7
- 0.10.5a8
- 0.10.5a9
- 0.10.6
- 0.10.6.post1
- 0.10.7
- 0.10.8
- 0.10.8.post1
- 0.10.9
- 0.9.41
- 0.9.42
- 0.9.42.post3
- 0.9.43
- 0.9.44
- 0.9.44.post1
- 0.9.44.post2
- 0.9.44.post3
- 0.9.45
- 0.9.46
- 0.9.47
- 0.9.48
- 0.9.49
- 0.9.50
- 0.9.50.post1
- 0.9.51
- 0.9.52
- 0.9.53
- 0.9.54
- 0.9.55
- 0.9.56
- Affected ranges
- ECOSYSTEM: < 0.10.24
Update to 0.10.24