p PatchFirst

CVE-2024-31111

CVE-2024-31111 · WordPress Core < 6.5.5 - Cross Site Scripting (XSS) vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Automattic WordPress allows Stored XSS.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9.

CVSS 6.5 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wordpress

    Versions
    • ≥ 6.5, ≤ 6.5.4: Affected; ≥ 6.5.5: Not affected (custom)
    • ≥ 6.4, ≤ 6.4.4: Affected; ≥ 6.4.5: Not affected (custom)
    • ≥ 6.3, ≤ 6.3.4: Affected; ≥ 6.3.5: Not affected (custom)
    • ≥ 6.2, ≤ 6.2.5: Affected; ≥ 6.2.6: Not affected (custom)
    • ≥ 6.1, ≤ 6.1.6: Affected; ≥ 6.1.7: Not affected (custom)
    • ≥ 6.0, ≤ 6.0.8: Affected; ≥ 6.0.9: Not affected (custom)
    • ≥ 5.9, ≤ 5.9.9: Affected; ≥ 5.9.10: Not affected (custom)

    Update to 5.9.10; Update to 6.0.9; Update to 6.1.7; Update to 6.2.6; Update to 6.3.5; Update to 6.4.5; Update to 6.5.5

  • wordpress Debian:12

    Versions
    • 6.1.1+dfsg1-1
    • 6.1.6+dfsg1-0+deb12u1
    Affected ranges
    • ECOSYSTEM: < 6.1.9+dfsg1-0+deb12u1

    Update to 6.1.9+dfsg1-0+deb12u1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 6.5.5+dfsg1-1

    Update to 6.5.5+dfsg1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 6.5.5+dfsg1-1

    Update to 6.5.5+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:18.04:LTS

    Versions
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:20.04:LTS

    Versions
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:22.04:LTS

    Versions
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:24.04:LTS

    Versions
    • 6.2+dfsg1-1ubuntu1
    • 6.4.3+dfsg1-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →