CVE-2024-31979
CVE-2024-31979 · Apache StreamPipes: Possibility of SSRF in pipeline element installation process
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements. Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
CVSS 7.5 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache streampipes
- Versions
- ≥ 0, ≤ 0.93.0: Affected (maven)
No fix published
org.apache.streampipes:streampipes-parent Maven
- Versions
- 0.66.0
- 0.67.0
- 0.68.0
- 0.69.0
- 0.70.0
- 0.90.0
- 0.91.0
- 0.92.0
- 0.93.0
- Affected ranges
- ECOSYSTEM: < 0.95.0
Update to 0.95.0
streampipes PyPI
- Versions
- 0.0.2.dev0
- 0.91.0
- 0.92.0
- 0.93.0
- Affected ranges
- ECOSYSTEM: < 0.95.0
Update to 0.95.0