CVE-2024-32111
CVE-2024-32111 · WordPress core < 6.5.5 - Auth. Arbitrary .html File Read (Windows Only) vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Automattic WordPress allows Relative Path Traversal.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9, from 5.8 through 5.8.9, from 5.7 through 5.7.11, from 5.6 through 5.6.13, from 5.5 through 5.5.14, from 5.4 through 5.4.15, from 5.3 through 5.3.17, from 5.2 through 5.2.20, from 5.1 through 5.1.18, from 5.0 through 5.0.21, from 4.9 through 4.9.25, from 4.8 through 4.8.24, from 4.7 through 4.7.28, from 4.6 through 4.6.28, from 4.5 through 4.5.31, from 4.4 through 4.4.32, from 4.3 through 4.3.33, from 4.2 through 4.2.37, from 4.1 through 4.1.40.
CVSS 5.0 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress
- Versions
- ≥ 6.5, ≤ 6.5.4: Affected; ≥ 6.5.5: Not affected (custom)
- ≥ 6.4, ≤ 6.4.4: Affected; ≥ 6.4.5: Not affected (custom)
- ≥ 6.3, ≤ 6.3.4: Affected; ≥ 6.3.5: Not affected (custom)
- ≥ 6.2, ≤ 6.2.5: Affected; ≥ 6.2.6: Not affected (custom)
- ≥ 6.1, ≤ 6.1.6: Affected; ≥ 6.1.7: Not affected (custom)
- ≥ 6.0, ≤ 6.0.8: Affected; ≥ 6.0.9: Not affected (custom)
- ≥ 5.9, ≤ 5.9.9: Affected; ≥ 5.9.10: Not affected (custom)
- ≥ 5.8, ≤ 5.8.9: Affected; ≥ 5.8.10: Not affected (custom)
- ≥ 5.7, ≤ 5.7.11: Affected; ≥ 5.7.12: Not affected (custom)
- ≥ 5.6, ≤ 5.6.13: Affected; ≥ 5.6.14: Not affected (custom)
- ≥ 5.5, ≤ 5.5.14: Affected; ≥ 5.5.15: Not affected (custom)
- ≥ 5.4, ≤ 5.4.15: Affected; ≥ 5.4.16: Not affected (custom)
- ≥ 5.3, ≤ 5.3.17: Affected; ≥ 5.3.18: Not affected (custom)
- ≥ 5.2, ≤ 5.2.20: Affected; ≥ 5.2.21: Not affected (custom)
- ≥ 5.1, ≤ 5.1.18: Affected; ≥ 5.1.19: Not affected (custom)
- ≥ 5.0, ≤ 5.0.21: Affected; ≥ 5.0.22: Not affected (custom)
- ≥ 4.9, ≤ 4.9.25: Affected; ≥ 4.9.26: Not affected (custom)
- ≥ 4.8, ≤ 4.8.24: Affected; ≥ 4.8.25: Not affected (custom)
- ≥ 4.7, ≤ 4.7.28: Affected; ≥ 4.7.29: Not affected (custom)
- ≥ 4.6, ≤ 4.6.28: Affected; ≥ 4.6.29: Not affected (custom)
- ≥ 4.5, ≤ 4.5.31: Affected; ≥ 4.5.32: Not affected (custom)
- ≥ 4.4, ≤ 4.4.32: Affected; ≥ 4.4.33: Not affected (custom)
- ≥ 4.3, ≤ 4.3.33: Affected; ≥ 4.3.34: Not affected (custom)
- ≥ 4.2, ≤ 4.2.37: Affected; ≥ 4.2.38: Not affected (custom)
- ≥ 4.1, ≤ 4.1.40: Affected; ≥ 4.1.41: Not affected (custom)
Update to 4.1.41; Update to 4.2.38; Update to 4.3.34; Update to 4.4.33; Update to 4.5.32; Update to 4.6.29; Update to 4.7.29; Update to 4.8.25; Update to 4.9.26; Update to 5.0.22; Update to 5.1.19; Update to 5.2.21; Update to 5.3.18; Update to 5.4.16; Update to 5.5.15; Update to 5.6.14; Update to 5.7.12; Update to 5.8.10; Update to 5.9.10; Update to 6.0.9; Update to 6.1.7; Update to 6.2.6; Update to 6.3.5; Update to 6.4.5
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:24.04:LTS
- Versions
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published