CVE-2024-32964
CVE-2024-32964 · lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Lobe Chat is a chatbot framework that supports speech synthesis, multimodal, and extensible Function Call plugin system. Prior to 0.150.6, lobe-chat had an unauthorized Server-Side Request Forgery vulnerability in the /api/proxy endpoint. An attacker can construct malicious requests to cause Server-Side Request Forgery without logging in, attack intranet services, and leak sensitive information.
CVSS 9.0 · Critical · EPSS 53.0% · Public exploit · Fix available
- Published
- Updated
Stack: node
Affected products and versions
lobe-chat
- Versions
- <= 0.150.5: Affected
No fix published
@lobehub/chat npm
- Affected ranges
- SEMVER: < 0.150.6
Update to 0.150.6