CVE-2024-32965
CVE-2024-32965 · ssrf vulnerability in lobe-chat
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Lobe Chat is an open-source, AI chat framework. Versions of lobe-chat prior to 1.19.13 have an unauthorized ssrf vulnerability. An attacker can construct malicious requests to cause SSRF without logging in, attack intranet services, and leak sensitive information. The jwt token header X-Lobe-Chat-Auth strored proxy address and OpenAI API Key, can be modified to scan an internal network in the target lobe-web environment. This issue has been addressed in release version 1.19.13 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 8.1 · High · EPSS 26.1% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
lobe-chat
- Versions
- < 1.19.13: Affected
No fix published
@lobehub/chat npm
- Affected ranges
- SEMVER: < 1.19.13
Update to 1.19.13