CVE-2024-33999
CVE-2024-33999 · moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The referrer URL used by MFA required additional sanitizing, rather than being used directly.
CVSS 9.8 · Critical · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
moodle/moodle Packagist
- Versions
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- Affected ranges
- ECOSYSTEM: ≥ 4.3.0, < 4.3.4
Update to 4.3.4
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published