CVE-2024-34067
CVE-2024-34067 · Multiple cross site scripting (XSS) vulnerabilities in the admin area of Pterodactyl panel
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Pterodactyl is a free, open-source game server management panel built with PHP, React, and Go. Importing a malicious egg or gaining access to wings instance could lead to cross site scripting (XSS) on the panel, which could be used to gain an administrator account on the panel. Specifically, the following things are impacted: Egg Docker images and Egg variables: Name, Environment variable, Default value, Description, Validation rules. Additionally, certain fields would reflect malicious input, but it would require the user knowingly entering such input to have an impact. To iterate, this would require an administrator to perform actions and can't be triggered by a normal panel user. This issue has has been addressed in version 1.11.6 and users are advised to upgrade. No workaround is available other than updating to the latest version of the panel.
CVSS 6.1 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
panel
- Versions
- < 1.11.6: Affected
No fix published
pterodactyl/panel Packagist
- Versions
- v0.1.0-beta
- v0.1.1-beta
- v0.1.2-beta
- v0.2.0-beta
- v0.3.0-beta
- v0.4.0-beta
- v0.4.1-beta
- v0.5.0
- v0.5.0-rc.1
- v0.5.0-rc.2
- v0.5.1
- v0.5.2
- v0.5.3
- v0.5.4
- v0.5.5
- v0.5.6
- v0.5.7
- v0.6.0
- v0.6.0-beta.1
- v0.6.0-beta.2
- v0.6.0-beta.2.1
- v0.6.0-rc.1
- v0.6.1
- v0.6.2
- v0.6.3
- v0.6.4
- v0.7.0
- v0.7.0-beta.1
- v0.7.0-beta.2
- v0.7.0-beta.3
- v0.7.0-beta.4
- v0.7.0-rc.1
- v0.7.0-rc.2
- v0.7.1
- v0.7.10
- v0.7.11
- v0.7.12
- v0.7.13
- v0.7.14
- v0.7.15
- v0.7.16
- v0.7.17
- v0.7.18
- v0.7.19
- v0.7.2
- v0.7.3
- v0.7.4
- v0.7.5
- v0.7.6
- v0.7.7
- v0.7.8
- v0.7.9
- v0.8.0-alpha.1
- v0.8.0-alpha.2
- v1.0.0
- v1.0.0-beta.1
- v1.0.0-beta.2
- v1.0.0-beta.3
- v1.0.0-beta.4
- v1.0.0-beta.5
- v1.0.0-beta.6
- v1.0.0-beta.7
- v1.0.0-rc.1
- v1.0.0-rc.2
- v1.0.0-rc.3
- v1.0.0-rc.4
- v1.0.0-rc.5
- v1.0.0-rc.6
- v1.0.0-rc.7
- v1.0.1
- v1.0.2
- v1.0.3
- v1.1.0
- v1.1.1
- v1.1.2
- v1.1.3
- v1.10.0
- v1.10.1
- v1.10.2
- v1.10.3
- v1.10.4
- v1.11.0
- v1.11.0-rc.1
- v1.11.0-rc.2
- v1.11.1
- v1.11.2
- v1.11.3
- v1.11.4
- v1.11.5
- v1.2.0
- v1.2.1
- v1.2.2
- v1.3.0
- v1.3.1
- v1.3.2
- v1.4.0
- v1.4.1
- v1.4.2
- v1.5.0
- v1.5.1
- v1.6.0
- v1.6.1
- v1.6.2
- v1.6.3
- v1.6.5
- v1.6.6
- v1.7.0
- v1.8.0
- v1.8.1
- v1.9.0
- v1.9.1
- v1.9.2
- Affected ranges
- ECOSYSTEM: < 1.11.6
Update to 1.11.6
Original sources
- https://github.com/pterodactyl/panel/security/advisories/GHSA-384w-wffr-x63q
- https://github.com/pterodactyl/panel/commit/0dad4c5a488661f9adc27dd311542516d9bfa0f2
- https://github.com/pterodactyl/panel/commit/1172d71d31561c4e465dabdf6b838e64de48ad16
- https://github.com/pterodactyl/panel/commit/f671046947e4695b5e1c647df79305c1cefdf817
- https://nvd.nist.gov/vuln/detail/CVE-2024-34067