CVE-2024-3660
CVE-2024-3660 · Arbitrary code injection vulnerability in Keras framework < 2.13
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A arbitrary code injection vulnerability in TensorFlow's Keras framework (<2.13) allows attackers to execute arbitrary code with the same permissions as the application using a model that allow arbitrary code irrespective of the application.
CVSS 9.8 · Critical · EPSS 1.7% · Fix available
- Published
- Updated
Affected products and versions
keras
- Versions
- ≥ *, < 2.13: Affected (custom)
Update to 2.13
keras Debian:11
- Versions
- 2.3.1+dfsg-3
- 2.3.1+dfsg2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
keras PyPI
- Versions
- 0.2.0
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.1.0
- 1.1.1
- 1.1.2
- 1.2.0
- 1.2.1
- 1.2.2
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.10.0
- 2.10.0rc0
- 2.10.0rc1
- 2.11.0
- 2.11.0rc0
- 2.11.0rc1
- 2.11.0rc2
- 2.11.0rc3
- 2.12.0
- 2.12.0rc0
- 2.12.0rc1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.5.0rc0
- 2.6.0
- 2.6.0rc0
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.7.0
- 2.7.0rc0
- 2.7.0rc2
- 2.8.0
- 2.8.0rc0
- 2.8.0rc1
- 2.9.0
- 2.9.0rc0
- 2.9.0rc1
- 2.9.0rc2
- Affected ranges
- ECOSYSTEM: < 2.13.1rc0
Update to 2.13.1rc0
keras Ubuntu:18.04:LTS
- Versions
- 1.0.7-2
- 2.1.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
keras Ubuntu:20.04:LTS
- Versions
- 2.2.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published