CVE-2024-38428
CVE-2024-38428
This page contains facts from public vulnerability sources. Check the original advisory before updating.
url.c in GNU Wget through 1.24.5 mishandles semicolons in the userinfo subcomponent of a URI, and thus there may be insecure behavior in which data that was supposed to be in the userinfo subcomponent is misinterpreted to be part of the host subcomponent.
CVSS 9.1 · Critical · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wget Debian:12
- Versions
- 1.21.3-1
- Affected ranges
- ECOSYSTEM: < 1.21.3-1+deb12u1
Update to 1.21.3-1+deb12u1
wget Debian:13
- Affected ranges
- ECOSYSTEM: < 1.24.5-2
Update to 1.24.5-2
wget Debian:14
- Affected ranges
- ECOSYSTEM: < 1.24.5-2
Update to 1.24.5-2
wget Ubuntu:Pro:14.04:LTS
- Versions
- 1.14-2ubuntu1
- 1.14-5ubuntu1
- 1.15-1ubuntu1
- 1.15-1ubuntu1.14.04.1
- 1.15-1ubuntu1.14.04.2
- 1.15-1ubuntu1.14.04.3
- 1.15-1ubuntu1.14.04.4
- 1.15-1ubuntu1.14.04.5
- Affected ranges
- ECOSYSTEM: < 1.15-1ubuntu1.14.04.5+esm2
Update to 1.15-1ubuntu1.14.04.5+esm2
wget Ubuntu:Pro:16.04:LTS
- Versions
- 1.16.1-1ubuntu1
- 1.17.1-1ubuntu1
- 1.17.1-1ubuntu1.1
- 1.17.1-1ubuntu1.2
- 1.17.1-1ubuntu1.3
- 1.17.1-1ubuntu1.4
- 1.17.1-1ubuntu1.5
- Affected ranges
- ECOSYSTEM: < 1.17.1-1ubuntu1.5+esm1
Update to 1.17.1-1ubuntu1.5+esm1
wget Ubuntu:Pro:18.04:LTS
- Versions
- 1.19.1-3ubuntu1
- 1.19.1-3ubuntu1.1
- 1.19.2-1ubuntu1
- 1.19.3-2ubuntu1
- 1.19.4-1ubuntu2
- 1.19.4-1ubuntu2.1
- 1.19.4-1ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 1.19.4-1ubuntu2.2+esm1
Update to 1.19.4-1ubuntu2.2+esm1
wget Ubuntu:20.04:LTS
- Versions
- 1.20.3-1ubuntu1
- 1.20.3-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.20.3-1ubuntu2.1
Update to 1.20.3-1ubuntu2.1
wget Ubuntu:22.04:LTS
- Versions
- 1.21-1ubuntu3
- 1.21-1ubuntu4
- 1.21-1ubuntu5
- 1.21.2-2ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.21.2-2ubuntu1.1
Update to 1.21.2-2ubuntu1.1
wget Ubuntu:24.04:LTS
- Versions
- 1.21.3-1ubuntu1
- 1.21.4-1ubuntu1
- 1.21.4-1ubuntu2
- 1.21.4-1ubuntu3
- 1.21.4-1ubuntu4
- Affected ranges
- ECOSYSTEM: < 1.21.4-1ubuntu4.1
Update to 1.21.4-1ubuntu4.1
Original sources
- https://lists.gnu.org/archive/html/bug-wget/2024-06/msg00005.html
- https://git.savannah.gnu.org/cgit/wget.git/commit/?id=ed0c7c7e0e8f7298352646b2fd6e06a11e242ace
- https://security.netapp.com/advisory/ntap-20241115-0005/
- https://lists.debian.org/debian-lts-announce/2025/04/msg00029.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-38428