p PatchFirst

CVE-2024-3958

CVE-2024-3958 · Improper Control of Generation of Code ('Code Injection') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. An issue was found that allows someone to abuse a discrepancy between the Web application display and the git command line interface to social engineer victims into cloning non-trusted code.

CVSS 5.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 0, < 17.0.6: Affected (semver)
    • ≥ 17.1, < 17.1.4: Affected (semver)
    • ≥ 17.2, < 17.2.2: Affected (semver)

    Update to 17.0.6; Update to 17.1.4; Update to 17.2.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →