CVE-2024-40101
CVE-2024-40101
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A Reflected Cross-site scripting (XSS) vulnerability exists in '/search' in microweber 2.0.15 and earlier allowing unauthenticated remote attackers to inject arbitrary web script or HTML via the 'keywords' parameter.
CVSS 7.2 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
microweber/microweber Packagist
- Versions
- 0.9.346
- 0.93
- 0.931
- 0.934
- 0.951
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.1
- v1.2.10
- v1.2.11
- v1.2.12
- v1.2.13
- v1.2.14
- v1.2.15
- v1.2.16
- v1.2.17
- v1.2.18
- v1.2.19
- v1.2.20
- v1.2.21
- v1.2.3
- v1.2.4
- v1.2.5
- v1.2.6
- v1.2.7
- v1.2.8
- v1.2.9
- v1.3.0
- v1.3.1
- v1.3.2
- v1.3.3
- v1.3.4
- v2.0.0
- v2.0.1
- v2.0.10
- v2.0.11
- v2.0.12
- v2.0.13
- v2.0.14
- v2.0.15
- v2.0.3
- v2.0.4
- v2.0.5
- v2.0.6
- v2.0.7
- v2.0.8
- v2.0.9
- Affected ranges
- ECOSYSTEM: < 2.0.16
Update to 2.0.16