p PatchFirst

CVE-2024-42008

CVE-2024-42008

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A Cross-Site Scripting vulnerability in rcmail_action_mail_get->run() in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of a victim via a malicious e-mail attachment served with a dangerous Content-Type header.

CVSS 9.3 · Critical · EPSS 34.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • roundcube Debian:12

    Versions
    • 1.6.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.3+dfsg-1
    • 1.6.3+dfsg-1~deb12u1
    • 1.6.3+dfsg-2
    • 1.6.4+dfsg-1
    • 1.6.4+dfsg-1~deb12u1
    • 1.6.5+dfsg-1
    • 1.6.5+dfsg-1+deb12u2
    • 1.6.5+dfsg-1~deb12u1
    Affected ranges
    • ECOSYSTEM: < 1.6.5+dfsg-1+deb12u3

    Update to 1.6.5+dfsg-1+deb12u3

  • roundcube Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.8+dfsg-1

    Update to 1.6.8+dfsg-1

  • roundcube Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.8+dfsg-1

    Update to 1.6.8+dfsg-1

  • roundcube Ubuntu:Pro:22.04:LTS

    Versions
    • 1.4.11+dfsg.1-4
    • 1.5.0+dfsg.1-2
    • 1.5.0+dfsg.1-2ubuntu0.1~esm1
    • 1.5.0+dfsg.1-2ubuntu0.1~esm2
    • 1.5.0+dfsg.1-2ubuntu0.1~esm3
    • 1.5.0+dfsg.1-2ubuntu0.1~esm4
    • 1.5.0+dfsg.1-2ubuntu0.1~esm5
    Affected ranges
    • ECOSYSTEM: < 1.5.0+dfsg.1-2ubuntu0.1~esm6

    Update to 1.5.0+dfsg.1-2ubuntu0.1~esm6

  • roundcube Ubuntu:Pro:24.04:LTS

    Versions
    • 1.6.2+dfsg-1
    • 1.6.4+dfsg-1
    • 1.6.5+dfsg-1
    • 1.6.6+dfsg-1
    • 1.6.6+dfsg-2
    • 1.6.6+dfsg-2ubuntu0.1
    • 1.6.6+dfsg-2ubuntu0.1+esm1
    • 1.6.6+dfsg-2ubuntu0.1+esm2
    Affected ranges
    • ECOSYSTEM: < 1.6.6+dfsg-2ubuntu0.1+esm3

    Update to 1.6.6+dfsg-2ubuntu0.1+esm3

Original sources

Check your server →