CVE-2024-42461
CVE-2024-42461
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because BER-encoded signatures are allowed.
CVSS 5.3 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-elliptic Debian:12
- Versions
- 6.5.4~dfsg-2
- 6.5.7+dfsg-1
- 6.6.1+dfsg+~6.4.18-1
- 6.6.1+dfsg+~6.4.18-2
- 6.6.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Debian:13
- Affected ranges
- ECOSYSTEM: < 6.5.7+dfsg-1
Update to 6.5.7+dfsg-1
node-elliptic Debian:14
- Affected ranges
- ECOSYSTEM: < 6.5.7+dfsg-1
Update to 6.5.7+dfsg-1
elliptic npm
- Affected ranges
- SEMVER: ≥ 5.2.1, < 6.5.7
Update to 6.5.7
node-elliptic Ubuntu:18.04:LTS
- Versions
- 6.4.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Ubuntu:20.04:LTS
- Versions
- 6.5.1~dfsg-1
- 6.5.1~dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Ubuntu:22.04:LTS
- Versions
- 6.5.4~dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Ubuntu:24.04:LTS
- Versions
- 6.5.4~dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Ubuntu:25.10
- Versions
- 6.6.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Ubuntu:26.10
- Versions
- 6.6.1+dfsg+~6.4.18-1
- 6.6.1+dfsg+~6.4.18-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-elliptic Ubuntu:26.04:LTS
- Versions
- 6.6.1+dfsg-1
- 6.6.1+dfsg+~6.4.18-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published