p PatchFirst

CVE-2024-4311

CVE-2024-4311 · Lack of login attempt rate-limiting in zenml-io/zenml

This page contains facts from public vulnerability sources. Check the original advisory before updating.

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

CVSS 5.4 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • zenml-io/zenml

    Versions
    • ≥ unspecified, < 0.57.0: Affected (custom)

    Update to 0.57.0

  • zenml PyPI

    Versions
    • 0.0.1rc1
    • 0.0.1rc2
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.3rc0
    • 0.1.4
    • 0.1.5
    • 0.10.0
    • 0.11.0
    • 0.12.0
    • 0.13.0
    • 0.13.1
    • 0.13.2
    • 0.2.0
    • 0.2.0rc1
    • 0.2.0rc2
    • 0.20.0
    • 0.20.0rc1
    • 0.20.1
    • 0.20.2
    • 0.20.3
    • 0.20.4
    • 0.20.5
    • 0.21.0
    • 0.21.1
    • 0.22.0
    • 0.23.0
    • 0.3.1
    • 0.3.1rc0
    • 0.3.2
    • 0.3.3
    • 0.3.3rc0
    • 0.3.4
    • 0.3.4rc0
    • 0.3.5
    • 0.3.5rc0
    • 0.3.6
    • 0.3.6.1
    • 0.3.6rc0
    • 0.3.7
    • 0.3.7.1rc0
    • 0.3.7.1rc1
    • 0.3.7.1rc3
    • 0.3.7.1rc4
    • 0.3.7rc0
    • 0.3.8
    • 0.3.9rc1
    • 0.3.9rc2
    • 0.30.0
    • 0.30.0rc0
    • 0.30.0rc1
    • 0.30.0rc2
    • 0.30.0rc3
    • 0.31.0
    • 0.31.1
    • 0.32.0
    • 0.32.1
    • 0.33.0
    • 0.34.0
    • 0.35.0
    • 0.35.1
    • 0.36.0
    • 0.36.1
    • 0.37.0
    • 0.38.0
    • 0.39.0
    • 0.39.1
    • 0.40.0
    • 0.40.1
    • 0.40.2
    • 0.40.3
    • 0.41.0
    • 0.42.0
    • 0.42.1
    • 0.42.2
    • 0.43.0
    • 0.43.1
    • 0.44.0
    • 0.44.1
    • 0.44.2
    • 0.44.3
    • 0.44.4
    • 0.45.0
    • 0.45.1
    • 0.45.2
    • 0.45.3
    • 0.45.4
    • 0.45.5
    • 0.45.6
    • 0.46.0
    • 0.46.1
    • 0.47.0
    • 0.5.0
    • 0.5.0rc1
    • 0.5.0rc2
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • 0.5.6
    • 0.5.7
    • 0.50.0
    • 0.51.0
    • 0.52.0
    • 0.53.0
    • 0.53.1
    • 0.54.0
    • 0.54.1
    • 0.55.0
    • 0.55.1
    • 0.55.2
    • 0.55.3
    • 0.55.4
    • 0.55.5
    • 0.56.0
    • 0.56.1
    • 0.56.2
    • 0.56.3
    • 0.56.4
    • 0.57.0rc1
    • 0.6.0
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.8.0
    • 0.8.1
    • 0.8.1rc0
    • 0.9.0
    Affected ranges
    • ECOSYSTEM: < 0.57.0rc2

    Update to 0.57.0rc2

Original sources

Check your server →