CVE-2024-43168
CVE-2024-43168 · Unbound: heap-buffer-overflow in unbound
This page contains facts from public vulnerability sources. Check the original advisory before updating.
DISPUTE NOTE: this issue does not pose a security risk as it (according to analysis by the original software developer, NLnet Labs) falls within the expected functionality and security controls of the application. Red Hat has made a claim that there is a security risk within Red Hat products. NLnet Labs has no further information about the claim, and suggests that affected Red Hat customers refer to available Red Hat documentation or support channels. ORIGINAL DESCRIPTION: A heap-buffer-overflow flaw was found in the cfg_mark_ports function within Unbound's config_file.c, which can lead to memory corruption. This issue could allow an attacker with local access to provide specially crafted input, potentially causing the application to crash or allowing arbitrary code execution. This could result in a denial of service or unauthorized actions on the system.
CVSS 4.8 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat enterprise linux 6
No fix published
red hat enterprise linux 7
No fix published
red hat enterprise linux 8
No fix published
red hat enterprise linux 9
No fix published
red hat openshift container platform 4
No fix published
red hat openstack platform 16.2
No fix published
red hat openstack platform 17.1
No fix published
red hat openstack platform 18.0
No fix published
unbound Debian:12
- Versions
- 1.17.1-2
- 1.17.1-2+deb12u1
- 1.17.1-2+deb12u2
- Affected ranges
- ECOSYSTEM: < 1.17.1-2+deb12u3
Update to 1.17.1-2+deb12u3
unbound Debian:13
- Affected ranges
- ECOSYSTEM: < 1.20.0-1
Update to 1.20.0-1
unbound Debian:14
- Affected ranges
- ECOSYSTEM: < 1.20.0-1
Update to 1.20.0-1
unbound Ubuntu:Pro:14.04:LTS
- Versions
- 1.4.20-1
- 1.4.21-1
- 1.4.21-1ubuntu1
- 1.4.21-1ubuntu2
- 1.4.22-1ubuntu1
- 1.4.22-1ubuntu2
- 1.4.22-1ubuntu3
- 1.4.22-1ubuntu4
- 1.4.22-1ubuntu4.14.04.1
- 1.4.22-1ubuntu4.14.04.2
- 1.4.22-1ubuntu4.14.04.3
- Affected ranges
- ECOSYSTEM: < 1.4.22-1ubuntu4.14.04.3+esm1
Update to 1.4.22-1ubuntu4.14.04.3+esm1
unbound Ubuntu:Pro:16.04:LTS
- Versions
- 1.4.22-1ubuntu6
- 1.5.7-1ubuntu1
- 1.5.7-1ubuntu2
- 1.5.8-1ubuntu1
- 1.5.8-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.5.8-1ubuntu1.1+esm1
Update to 1.5.8-1ubuntu1.1+esm1
unbound Ubuntu:Pro:18.04:LTS
- Versions
- 1.6.5-1
- 1.6.7-1
- 1.6.7-1build1
- 1.6.7-1ubuntu1
- 1.6.7-1ubuntu2
- 1.6.7-1ubuntu2.1
- 1.6.7-1ubuntu2.2
- 1.6.7-1ubuntu2.3
- 1.6.7-1ubuntu2.4
- 1.6.7-1ubuntu2.5
- 1.6.7-1ubuntu2.6
- Affected ranges
- ECOSYSTEM: < 1.6.7-1ubuntu2.6+esm2
Update to 1.6.7-1ubuntu2.6+esm2
unbound Ubuntu:20.04:LTS
- Versions
- 1.9.0-2ubuntu1
- 1.9.0-2ubuntu2
- 1.9.4-2
- 1.9.4-2ubuntu1
- 1.9.4-2ubuntu1.1
- 1.9.4-2ubuntu1.2
- 1.9.4-2ubuntu1.3
- 1.9.4-2ubuntu1.4
- 1.9.4-2ubuntu1.5
- 1.9.4-2ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 1.9.4-2ubuntu1.8
Update to 1.9.4-2ubuntu1.8
unbound Ubuntu:22.04:LTS
- Versions
- 1.13.1-1ubuntu1
- 1.13.1-1ubuntu3
- 1.13.1-1ubuntu5
- 1.13.1-1ubuntu5.1
- 1.13.1-1ubuntu5.2
- 1.13.1-1ubuntu5.3
- 1.13.1-1ubuntu5.4
- 1.13.1-1ubuntu5.5
- Affected ranges
- ECOSYSTEM: < 1.13.1-1ubuntu5.7
Update to 1.13.1-1ubuntu5.7
unbound Ubuntu:24.04:LTS
- Versions
- 1.17.1-2
- 1.18.0-2ubuntu1
- 1.18.0-2ubuntu2
- 1.19.1-1ubuntu1
- 1.19.2-1ubuntu1
- 1.19.2-1ubuntu3
- 1.19.2-1ubuntu3.1
- Affected ranges
- ECOSYSTEM: < 1.19.2-1ubuntu3.2
Update to 1.19.2-1ubuntu3.2
Original sources
- https://access.redhat.com/security/cve/CVE-2024-43168
- https://bugzilla.redhat.com/show_bug.cgi?id=2303462
- https://github.com/NLnetLabs/unbound/issues/1039
- https://github.com/NLnetLabs/unbound/pull/1040/files
- https://lists.debian.org/debian-lts-announce/2024/09/msg00046.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-43168