CVE-2024-4317
CVE-2024-4317 · PostgreSQL pg_stats_ext and pg_stats_ext_exprs lack authorization checks
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Missing authorization in PostgreSQL built-in views pg_stats_ext and pg_stats_ext_exprs allows an unprivileged database user to read most common values and other statistics from CREATE STATISTICS commands of other users. The most common values may reveal column values the eavesdropper could not otherwise read or results of functions they cannot execute. Installing an unaffected version only fixes fresh PostgreSQL installations, namely those that are created with the initdb utility after installing that version. Current PostgreSQL installations will remain vulnerable until they follow the instructions in the release notes. Within major versions 14-16, minor versions before PostgreSQL 16.3, 15.7, and 14.12 are affected. Versions before PostgreSQL 14 are unaffected.
CVSS 3.1 · Low · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
postgresql
- Versions
- ≥ 16, < 16.3: Affected (rpm)
- ≥ 15, < 15.7: Affected (rpm)
- ≥ 14, < 14.12: Affected (rpm)
Update to 14.12; Update to 15.7; Update to 16.3
postgresql-15 Debian:12
- Versions
- 15.3-0+deb12u1
- 15.3-1
- 15.4-0+deb12u1
- 15.4-1
- 15.4-2
- 15.4-3
- 15.5-0+deb12u1
- 15.6-0+deb12u1
- Affected ranges
- ECOSYSTEM: < 15.7-0+deb12u1
Update to 15.7-0+deb12u1
postgresql-14 Ubuntu:22.04:LTS
- Versions
- 14.1-1ubuntu1
- 14.2-1
- 14.2-1ubuntu1
- 14.3-0ubuntu0.22.04.1
- 14.4-0ubuntu0.22.04.1
- 14.5-0ubuntu0.22.04.1
- 14.6-0ubuntu0.22.04.1
- 14.7-0ubuntu0.22.04.1
- 14.8-0ubuntu0.22.04.1
- 14.9-0ubuntu0.22.04.1
- 14.10-0ubuntu0.22.04.1
- 14.11-0ubuntu0.22.04.1
- Affected ranges
- ECOSYSTEM: < 14.12-0ubuntu0.22.04.1
Update to 14.12-0ubuntu0.22.04.1
postgresql-16 Ubuntu:24.04:LTS
- Versions
- 16.0-2
- 16.1-1
- 16.1-1build1
- 16.1-1build3
- 16.2-1
- 16.2-1ubuntu2
- 16.2-1ubuntu3
- 16.2-1ubuntu4
- Affected ranges
- ECOSYSTEM: < 16.3-0ubuntu0.24.04.1
Update to 16.3-0ubuntu0.24.04.1